[LRUG] rvm install help!

Adrian Stainforth adrian.stainforth at gmail.com
Mon Jan 17 05:05:25 PST 2011

Can anyone help me, I'm struggling with an RVM install with mysql.

I'm on Mac OSX 10.6 64bit and have installed rvm fine with 1.8.7 and rails
2.3.8 and then installed mysql server which is also 64bit.

I then tried to install the mysql gem using:

env ARCHFLAGS="-arch x86_64" rvm gem install mysql --

but then once I run rake db:setup or db:migrate I get the following error:

** Invoke db:setup (first_time)
** Invoke db:create (first_time)
** Invoke db:load_config (first_time)
** Invoke rails_env (first_time)
** Execute rails_env
** Execute db:load_config
** Execute db:create
Couldn't create database for {"reconnect"=>false, "encoding"=>"utf8",
"username"=>"root", "adapter"=>"mysql",
"database"=>"tabascopizza_development", "pool"=>5, "password"=>nil},
charset: utf8, collation: utf8_unicode_ci (if you set the charset manually,
make sure you have a matching collation)
** Invoke db:schema:load (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:schema:load
-- create_table("enters", {:force=>true})
rake aborted!
uninitialized constant MysqlCompat::MysqlRes

I've tried googling and most of them go on about making sure mysql and ruby
are 64bit which they are because I check with 'which ruby' & 'which mysql'

Does anyone have any ideas on why it is failing?


Kind Regards
Adrian Stainforth

Front-end Developer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lrug.org/pipermail/chat-lrug.org/attachments/20110117/1094499c/attachment-0003.html>

More information about the Chat mailing list